Forum:Adding a picture

From Traveller Wiki - Science-Fiction Adventure in the Far future
Jump to navigation Jump to search
Forums: Index > Watercooler > Adding a picture

I have never added a picture into a wiki before. I would to add one for the Flynn's Guide To Magic In Traveller article I created. How does one do this? I also have subsector map pictures derived from the Interstellar Wars year by year using POST function from 2098AD till 2302AD. derived from the Interstellar Wars. Not asking to be an administrator, just would like to get the pictures uploaded. What is the process?

In the menu to the left of the page, under the "toolbox" heading is a link to Upload file. The Upload page asks for the file on your local system, a name for the wiki, and a summary of the image.
  1. If you are uploading published book cover images, please add {{RpgBookImage}} to the summary (Brackets and all), which add some default text and categories to the image
  2. Please resize book cover images to be 350px or smaller in their largest dimension. This allows fitting the full image into the infobox.
  3. Please keep in mind the default image resize tool built into php/mediawiki does a poor job at best. If you want your re-sized images to look good, do so your self before uploading.
  4. There is a 2MB limit on the size of image. If you are convinced you need to upload an image larger than that, let me know as I can work around it.
Note to self: Add this to the help page
Tjoneslo (talk) 07:15, 17 April 2013 (EDT)
  1. Half the problem solved...I did not confirm my email. User rights issue. Now I get the page to do upload. Get a message with the following text:
  2. Bad Request
  3. Error Type: 400
  4. The URL that you requested — — does not exist on this server. You might want to re-check the spelling and the path.
  5. An e-mail has been sent to me regarding the problem. I apologize for any inconvenience caused and will do all I can to fix the error as soon as possible.
  6. You can use the menu at the top of the page or at the right to navigate to another section.

Nathan Brazil (talk) 09:07, 17 April 2013 (EDT)

How incredibly odd. I have a set of different users to verify functionality and tried without being able to reproduce the problem. I found your upload error in http logs and the only thing I can think of is the Apache ModSecurity package is causing this. Meaning ModSec thinks your jpeg file is corrupted in some way. I'd need to see the file to confirm that. Tjoneslo (talk) 20:09, 17 April 2013 (EDT)
Resolved. Must have been the picture itself. My personally created picture was fine. If you write the help, indicate the rights/email confirmation issue. Thanks for the assistance!

Nathan Brazil (talk) 18:07, 18 April 2013 (EDT)